summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30903672baa9..e2c445c1f0b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
_gitname=ots
pkgname=${_gitname}-git
-pkgver=324.b444494
+pkgver=641.f723823
pkgver() { cd $_gitname && echo $(git rev-list --count master).$(git rev-parse --short master); }
pkgrel=1
pkgdesc="OpenType fonts sanitiser. Supports TTF, WOFF, WOFF2 and other formats."
arch=('i686' 'x86_64')
url="https://github.com/khaledhosny/ots"
license=('custom')
-depends=('zlib')
+depends=('zlib' 'freetype2' 'libpng')
makedepends=('git')
provides=('ots')
conflicts=('ots')
@@ -24,5 +24,15 @@ build() {
package() {
cd $_gitname
make DESTDIR="$pkgdir/" install
+
+ ## remove useless "libz.a" and others
+ thelibdir="$pkgdir/usr/lib"
+ rm $thelibdir/*.a
+
+ ## remove pkgdir/usr/lib, if it empty after *.a cleaup
+ if [ -z "$(ls -A $thelibdir)" ]; then
+ rm -d "$thelibdir"
+ fi
+
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}