summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81e5053cecbb..8279fd64b4ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Balló György <ballogyor+arch at gmail dot com>
# Contributor: Felix Golatofski <contact@xdfr.de>
pkgname=outwiker
-pkgver=3.0.0.888
+pkgver=3.1.0.900
pkgrel=1
pkgdesc='Outliner and personal wiki with keeping the tree of notes in the form of directories on a disk'
arch=('any')
-url='https://jenyay.net/Outwiker/English'
+url='https://github.com/jenyay/outwiker'
license=('GPL3')
-depends=('python-cyhunspell' 'python-idna' 'python-pillow' 'python-pyparsing' 'python-wxpython')
-makedepends=('python-setuptools')
-source=("https://github.com/Jenyay/$pkgname/archive/stable_$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('5ac7b6654bef38bf57e98daddfd001e203020db96f97844eb0dfec3f2d7421ec')
+depends=('python-idna' 'python-pillow' 'python-psutil' 'python-pyparsing' 'python-wxpython')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/stable_$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('f4444811722dc8cf9afb967bf0bd07cf9e97eff46ce28564097c1b039af35ee3')
build() {
- cd $pkgname-stable_$pkgver
- python setup.py build
+ cd "$pkgname-stable_${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd $pkgname-stable_$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- make DESTDIR="$pkgdir" install
+ cd "$pkgname-stable_${pkgver}"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ make DESTDIR="$pkgdir" install
}