summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--[-rwxr-xr-x]PKGBUILD46
1 files changed, 31 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 137544b397d7..156ecd1d5fe5 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,39 @@
-# Maintainer: Darvin Delgado <dnmodder@gmail.com>
+# Maintainer: Brody <archfan at brodix dot de>
+# Contributor: Darvin Delgado <dnmodder@gmail.com>
+
pkgname=oversteer
-pkgver=0.5.5
+pkgver=0.8.1
pkgrel=1
-pkgdesc="Graphical application to configure Logitech Wheels."
-arch=("any")
-url="https://github.com/berarma/oversteer"
-license=('GPL3')
-depends=("python" "python-gobject" "python-matplotlib" "python-pyudev" "python-evdev" "python-xdg" "gettext" "appstream-glib" "desktop-file-utils")
-makedepends=("meson")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/berarma/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=("b522125a12ee6f6f9a4ba15e10ee1f47cca75c644f39f6dd45fdbf83f3e4b3e3")
+pkgdesc='Graphical application to configure Logitech Wheels'
+arch=(any)
+url=https://github.com/berarma/oversteer
+license=(GPL3)
+depends=(
+ appstream-glib
+ desktop-file-utils
+ gettext
+ python
+ python-cairo
+ python-evdev
+ python-gobject
+ python-matplotlib
+ python-pyudev
+ python-scipy
+ python-pyxdg
+)
+makedepends=(meson)
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/berarma/${pkgname}/archive/${pkgver}.tar.gz)
+sha256sums=(26479ef8b06da2373d67bbf803fb3e7b12bea37506ad3b9d5a3376b08d225d25)
build() {
- cd "$pkgname-$pkgver"
- meson build --prefix="/usr"
- ninja -C build
+ cd ${pkgname}-${pkgver}
+ meson build --prefix=/usr
+ ninja -C build
}
package() {
- cd "$pkgname-$pkgver"
- DESTDIR="$pkgdir/" ninja -C build install
+ cd ${pkgname}-${pkgver}
+ DESTDIR="${pkgdir}" ninja -C build install
}
+
+# vim: ts=2 sw=2 et: