summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..edb8847141db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Tomáš Vyčítal <tom.vycital@gmail.com>
+
+_pkgbase=pacman-conf-diff
+pkgname=$_pkgbase-git
+pkgver=v1.0.0.r0.gc6712f3
+pkgrel=1
+pkgdesc=''
+arch=('any')
+url='https://github.com/Thomaash/pacman-conf-diff'
+license=('Unlicense')
+makedepends=('git')
+depends=('python')
+provides=("$_pkgbase")
+conflicts=("$_pkgbase")
+options=(!strip !emptydirs)
+source=('git+https://github.com/Thomaash/pacman-conf-diff.git#branch=master')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ install -Dm 755 "$srcdir/$_pkgbase/${_pkgbase//-/_}" "$pkgdir/usr/bin"
+}
+
+