summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db8922b33c0f..46dee3ed8f0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,20 @@
pkgname=pacman-kernel-install-git
pkgver=r1.79dfc1c
-pkgrel=1
+pkgrel=2
pkgdesc='pacman hooks for kernel-install'
-url='https://gitlab.com/crazyh/pacman-kernel-install'
+url='https://github.com/crazyh/pacman-kernel-install'
license=('GPL')
-source=('kernel-install-add.hook' 'kernel-install-remove.hook')
-md5sums=(SKIP{,})
+source=('git+https://github.com/crazyh/pacman-kernel-install')
+md5sums=('SKIP')
arch=('any')
depends=('bash' 'mkinitcpio' 'systemd')
makedepends=('git')
provides=("${pkgname%-git}")
pkgver() {
+ cd "${pkgname%-git}"
+
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}