summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d83713c54fb7..2d36339e396e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=pacpush
-pkgver=2.26
-pkgrel=3
+pkgver=3.0
+pkgrel=1
pkgdesc="Utility to push an Arch hosts package and AUR caches to other hosts"
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
arch=("any")
-depends=("python>=3.10" "rsync" "sudo" "openssh" "python-requests"
- "python-ruamel-yaml" "pyalpm")
+depends=("python>=3.10" "rsync" "sudo" "openssh" "python-platformdirs"
+ "python-requests" "pyalpm")
makedepends=(python-setuptools python-build python-installer
python-wheel python-setuptools-scm)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('7a10ddc00b8d9f5c614963f9176f6ad2b568600f')
+sha1sums=('9fdca00bc5e46e7b790bee86f70c5346f3ef93fb')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -21,10 +21,6 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
-
- # Require special handling for python data files on Arch
- local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
- install -m 644 -t "$pkgdir/$pdir/$pkgname/" "$pkgname/${pkgname}.conf"
}
# vim:set ts=2 sw=2 et: