summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6701074e940f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Redson <redsonbr81@yandex.com>
+pkgname=pacw-git
+_pkgname=pacw
+pkgver=.2.5
+pkgrel=1
+pkgdesc="Pacman wrapper and utility tool."
+arch=('x86_64')
+url="https://github.com/S0raWasTaken/pacw"
+license=('MIT')
+makedepends=('cargo' 'git')
+source=("git+https://github.com/S0raWasTaken/pacw.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "${_pkgname}"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm 755 target/release/pacw "$pkgdir/usr/bin/pacw"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+}