summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4f066303c00..7b7e2960ab2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pakku-git
pkgver=0.13.r8.g1f6a5c6
-pkgrel=1
+pkgrel=2
pkgdesc='Pacman wrapper with AUR support with latest changes from github repo'
arch=('x86_64')
url="https://github.com/kitsunyan/pakku"
@@ -13,15 +13,21 @@ makedepends=('nim' 'git' 'asciidoc')
backup=('etc/pakku.conf')
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-source=("git+https://github.com/kitsunyan/${pkgname%-git}.git")
+source=("git+https://github.com/kitsunyan/${pkgname%-git}.git" remove_bash_completion.patch)
backup=('etc/pakku.conf')
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ 'f28b95bf409db284eb5384f0f56ad43b9465e7b7692759d870b28bb4cf45dd17')
pkgver() {
cd ${pkgname%-git}
git describe --tags|sed 's+-+.r+'|tr - .| cut -c2-
}
+prepare() {
+ cd ${pkgname%-git}
+ git apply "$srcdir"/remove_bash_completion.patch
+}
+
build() {
local addargs=()
grep -Fxq debug <<< "`printf '%s\n' "${options[@]}"`" &&