summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91cc9bf72abe..3fe5e5d431b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,12 @@
# Contributor: ilikenwf
# Contributor: American_Jesus
pkgname=palemoon
+_repo=palemoon-dev
epoch=1
-pkgver=29.4.4
+pkgver=29.4.5
+# Typically commit can be found at https://repo.palemoon.org/MoonchildProductions/Pale-Moon/releases
+# For 29.4.x see https://repo.palemoon.org/MoonchildProductions/palemoon-dev/releases
+_commit=179ec0a267
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -13,29 +17,34 @@ license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'alsa-lib'
'startup-notification')
makedepends=('python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'gcc10'
- 'libpulse')
+ 'libpulse' 'git')
optdepends=('libpulse: PulseAudio audio driver'
'ffmpeg: various video and audio support')
-# as of 29.4.1, upstream have switched to unsigned source archives instead of git
-source=("https://archive.palemoon.org/source/palemoon-${pkgver}.source.tar.xz"{,.sig}
+source=(git+"https://repo.palemoon.org/MoonchildProductions/${_repo}?signed#commit=${_commit}"
+ git+"https://repo.palemoon.org/MoonchildProductions/GRE"
mozconfig.in)
validpgpkeys=('3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC')
-sha1sums=('ace8fffe7d6851c7c0ec2c2555c0b8c19c7611b9'
+sha1sums=('SKIP'
'SKIP'
'5fc8e164a8c1731ad2cce6270c9b0e9a5145194c')
-sha256sums=('5d81f24fdc7cdb000d6ed5762459eda842b0b1f43fdad3a4be5e8edd5c8f7079'
+sha256sums=('SKIP'
'SKIP'
'a8ded94beaef0dfa4a5d6b109c1a669967cb7d38d4fe70b3a4d7725ef4b47394')
prepare() {
sed 's#%SRCDIR%#'"${srcdir}"'#g' mozconfig.in > mozconfig
+ cd ${_repo}
+ git submodule init
+ git config submodule.platform.url "${srcdir}/GRE"
+ git submodule update
}
build() {
+ cd ${_repo}
+
export MOZBUILD_STATE_PATH="${srcdir}/mozbuild"
export MOZCONFIG="${srcdir}/mozconfig"
export CPPFLAGS="${CPPFLAGS} -O2 -Wno-format-overflow"
- cd palemoon-source
./mach build
}
@@ -58,5 +67,5 @@ package() {
"${pkgdir}/usr/share/icons/hicolor/128x128/apps/${pkgname}.png"
# install desktop file
- install -Dm644 "${srcdir}/palemoon-source/palemoon/branding/official/palemoon.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${_repo}/palemoon/branding/official/palemoon.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}