summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39949907e277
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutantota dot com>
+pkgname=paleta
+pkgver=0.23
+pkgrel=1
+pkgdesc="Extract the dominant colors from any image."
+arch=('any')
+url="https://github.com/nate-xyz/paleta"
+license=('GPL3')
+depends=('libadwaita' 'python-colorthief' 'python-pillow' 'python-pyxdg')
+makedepends=('git' 'meson')
+checkdepends=('appstream-glib')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+_commit=cef94f4f54fd19652c727749d0fd8b3b0e88f055 # 0.2.3
+source=("git+https://github.com/nate-xyz/paleta.git#commit=$_commit")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson "$pkgname" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package () {
+ meson install -C build --destdir "$pkgdir"
+}