summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b68be064557f..f8b062c62faf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
-# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Maintainer: Zach Callear <zach@callear.org>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
# Contributor: Anders Bergh <anders1@gmail.com>
-# Contributer: Chris <alostengineer at narmos dot org>
+# Contributor: Chris <alostengineer at narmos dot org>
pkgname=pam_ssh_agent_auth
-pkgver=0.10.2
+pkgver=0.10.3
pkgrel=1
pkgdesc="PAM module which permits authentication for arbitrary services via ssh-agent."
arch=('i686' 'x86_64')
url="http://pamsshagentauth.sourceforge.net/"
license=('custom:OpenSSL')
source=(http://downloads.sourceforge.net/project/pamsshagentauth/$pkgname/v$pkgver/$pkgname-$pkgver.tar.bz2)
-md5sums=('a212baca7ce11d596bd8dcb222859ace')
-
+# I couldn't find a published checksum upstream, but Debian uses this md5sum:
+md5sums=('8dbe90ab3625e545036333e6f51ccf1d')
+makedepends=('openssl-1.0')
optdepends=('openssh: standard ssh-agent'
'gnupg: gpg ssh-agent' )
build() {
cd "$srcdir/$pkgname-$pkgver"
+ PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
+ CFLAGS+=" -I/usr/include/openssl-1.0" \
+ LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl" \
./configure --prefix=/usr --with-mantype=man --libexecdir=/usr/lib/security
make
}
@@ -26,5 +31,3 @@ package() {
install -Dm644 LICENSE.OpenSSL "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: