summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 884681e8ff19..14d2d4ccec7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=pandoc-bin
-pkgver=1.19.2.1
+pkgver=2.0.2
pkgrel=1
pkgdesc="Pandoc - executable only, without 750MB Haskell depends/makedepends"
url="http://pandoc.org"
@@ -16,35 +16,32 @@ optdepends=(
)
source=(
- "https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-1-amd64.deb"
+ "https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux.tar.gz"
- # Note that they use a git submodule for data/templates, so soure tarballs from github are incomplete.
- # Fetching from hackage gets us a complete tarball without writing our own `git submodule` commands.
- "https://hackage.haskell.org/package/pandoc-${pkgver}/pandoc-${pkgver}.tar.gz"
+ # The binary release doesn't have the datafiles, so we need to yoink those out of the source tarball, too.
+ "https://github.com/jgm/pandoc/archive/${pkgver}.tar.gz"
)
sha256sums=(
- "db828cbab2a6d0d33f3754c4061a844ae2d1f0a01cbb12c512ef109117595dd2"
- "08692f3d77bf95bb9ba3407f7af26de7c23134e7efcdafad0bdaf9050e2c7801"
+ "7d1374e53d85d4c7d86955c318b9f092ccce7ef0ba2ced11ec6aa158d61432c7"
+ "af6680238780efe57eb209ceb2166ed3954ee36fdab99f3c99ef9d0e3db96773"
)
package() {
- cd "${srcdir}"
+ cd "${srcdir}/pandoc-${pkgver}"
# To avoid having to download over a gigabyte of haskell makedepends (400-ish for ghc, plus 750 in libs), we
# just yoink the binary from static compiled binary distributed by pandoc:
- tar -zxf data.tar.gz
- cp -R usr "${pkgdir}/"
+ mkdir -p "${pkgdir}/usr/share/pandoc"
+ cp -R bin share "${pkgdir}/usr"
# Citeproc is provided by a different package, and depends on various other datafiles we don't handle here.
- rm "${pkgdir}/usr/bin/pandoc-citeproc"
- rm "${pkgdir}/usr/share/man/man1/pandoc-citeproc.1.gz"
- rm -R "${pkgdir}/usr/share/doc/pandoc-citeproc"
+ rm "${pkgdir}/usr/bin/pandoc-citeproc" "${pkgdir}/usr/share/man/man1/pandoc-citeproc.1.gz"
# We're still missing all the datafiles and so on. We get those from the source tarball...
- cd "pandoc-${pkgver}"
- mkdir -p "${pkgdir}/usr/share/pandoc/"
-
cp -R data "${pkgdir}/usr/share/pandoc/"
- cp COPYRIGHT "${pkgdir}/usr/share/pandoc/COPYRIGHT"
- cp MANUAL.txt "${pkgdir}/usr/share/pandoc/MANUAL.txt"
+ cp COPYRIGHT MANUAL.txt "${pkgdir}/usr/share/pandoc/"
+
+ # When pandoc stopped having templates as a submodule, they copied various github turds into their source
+ # tree, so let's tidy that up...
+ rm -R ${pkgdir}/usr/share/pandoc/data/templates/{.github,README.markdown}
}