summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3f83f60fa21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=pantheon-calculator-bzr
+pkgver=r132
+pkgrel=1
+pkgdesc='The Pantheon Calculator'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/pantheon-calculator'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('granite-bzr')
+makedepends=('bzr' 'cmake' 'vala')
+provides=('pantheon-calculator')
+conflicts=('pantheon-calculator')
+install='pantheon-calculator.install'
+source=('bzr+lp:pantheon-calculator')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pantheon-calculator
+
+ echo "r$(bzr revno)"
+}
+
+build() {
+ cd pantheon-calculator
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd pantheon-calculator/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: