summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8045832bb85f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer <shlomochoina@gmail.com>
+
+pkgname=pantheon-dock-git
+pkgver=r1966.ac87d90
+pkgrel=1
+pkgdesc='The Pantheon Dock'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/dock'
+license=('GPL3')
+depends=('libgee' 'bamf' 'plank' 'python')
+makedepends=('git' 'gnome-common' 'meson' 'vala' 'gnome-menus' 'libdbusmenu-gtk3')
+conflicts=('plank')
+provides=('plank')
+source=(pantheon-dock::git+$url)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pantheon-dock
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ arch-meson pantheon-dock build -Dapport=false -Denable-dbusmenu=yes -Denable-barriers=yes
+ ninja -C build
+}
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+
+# vim: ts=2 sw=2 et: