summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c8bb23b2016..2503577cd772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,46 @@
# Maintainer: Lex Black <autumn-wind@web.de>
pkgname=papermerge-core
-pkgver=2.1.9
+pkgver=3.0
pkgrel=1
pkgdesc="Open Source Document Management System for Digital Archives (server)"
arch=(any)
url="https://github.com/papermerge/papermerge-core"
license=(Apache)
-depends=(python-celery
+depends=(img2pdf
+ python-celery
python-configula
- python-daphne
+ python-django-filter
python-django-celery-results
- python-django-cors-headers
- python-django-channels
- python-django-channels-redis
python-django-dynamic-preferences
- python-django-filter
- python-django-haystack
python-django-modelcluster
- python-django-rest-framework
- python-django-rest-framework-json-api
python-django-rest-knox
python-django-taggit
- python-drf-spectacular
- python-drf-spectacular-sidecar
- python-elasticsearch
+ python-dj-config-url
+ python-dj-database-url
+ python-fastapi
+ python-httpx
+ python-jose
python-lxml
python-magic
+ python-mysqlclient
python-ocrmypdf-papermerge
+ python-passlib
python-pdf2image
python-persisting-theory
python-psycopg2
+ python-python-multipart
python-redis
+ python-salinic
python-uritemplate
- python-whoosh
- python-xapian-haystack
+ python-websockets
+ python-xapian
python-yaml
+ uvicorn
uwsgi-plugin-python)
makedepends=(python-build python-installer python-wheel python-poetry-core python-setuptools)
-source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz)
-sha256sums=('44581e2346f2216aec4e9fc333d599e9748b57f872c61b3b2cf868d5df45defc')
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz)
+sha256sums=('c66bbcce2402633de223d3dfcabd7aa1eee21b511985284b614691d2c1121668')
build() {