summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dfa7ec6a436
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=papirus-filezilla-themes-git
+pkgver=20161127
+pkgrel=1
+pkgdesc="Papirus theme for Filezilla (git version)"
+url="https://github.com/PapirusDevelopmentTeam/${pkgname%-git}"
+arch=('any')
+license=('GPL')
+depends=('filezilla')
+makedepends=('git')
+conflicts=('papirus-filezilla-theme' 'filezilla-papirus-theme' 'filezilla-papirus-theme-git')
+options=('!strip')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+package() {
+ cd $pkgname
+ install -d $pkgdir/usr/share/filezilla/resources
+ cp -a ./{papirus,papirus-dark} $pkgdir/usr/share/filezilla/resources/
+}