summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 19 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d216b2314449..6e3113dc1f23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
# Contributor: Edgard Castro <castro@edgard.org>
# Contributor: Frederic Bezies <fredbezies at gmail dot com>
@@ -6,38 +7,37 @@
# Contributor: Lucas SaliƩs Brum <lucas@archlinux.com.br>
pkgname=papirus-icon-theme-git
-pkgver=20201001.r3.g7da16ace69
+pkgver=20211201.r29.gc2c35ba3ab
pkgrel=1
epoch=1
-pkgdesc="Papirus icon theme (git version)"
-url="https://github.com/PapirusDevelopmentTeam/${pkgname%-git}"
+pkgdesc="A free and open source SVG icon theme based on Paper Icon Set"
arch=('any')
-license=('LGPL3')
+url="https://git.io/papirus-icon-theme"
+license=('GPL3')
+depends=('gtk-update-icon-cache')
makedepends=('git')
+optdepends=('hardcode-fixer-git: To deal with hardcoded application icons'
+ 'hardcode-tray-git: To fix hardcoded tray icons'
+ 'sif-git: To fix icons of running Steam games'
+ 'gnome-shell-extension-appindicator: Integrates AppIndicators on GNOME')
provides=("${pkgname%-git}")
-conflicts=(
- "${pkgname%-git}"
- "papirus-gtk-icon-theme"
- "papirus-gtk-icon-theme-git"
- "papirus-icon-theme-gtk"
- "papirus-icon-theme-gtk-git"
- "papirus-icon-theme-kde"
- "papirus-icon-theme-kde-git"
-)
-replaces=(
- "papirus-icon-theme-gtk-git"
- "papirus-icon-theme-kde-git"
-)
+conflicts=("${pkgname%-git}")
+install='alt-icons.install'
options=('!strip')
-source=("${pkgname}::git+${url}.git")
+source=('git+https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git')
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd "$srcdir/${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir" install
+}
+
+package() {
cd "${srcdir}/${pkgname}"
make DESTDIR="${pkgdir}/" install
}