summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07cd85b01dbd..0c301102e016 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,14 @@ provides=("parity")
url="https://github.com/ethcore/parity"
license=('GPL-3.0')
depends=('rocksdb')
-makedepends=('rust' 'cargo' 'git' 'python-pytoml')
+makedepends=('rust' 'cargo' 'git')
source=('git+https://github.com/ethcore/parity.git')
sha256sums=('SKIP')
pkgver() {
cd $_pkgname
- echo "$(python -c "print(__import__('pytoml').loads('\n'.join(open('Cargo.toml').read().splitlines()[:7]))['package']['version'])").$(git rev-list --count HEAD)"
+
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
}
build() {