summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9ccb3e4a382..60c142a02ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Guillaume Hayot <ghayot@postblue.info>
pkgname=parlatype
-pkgver=3.1
-pkgrel=1
+pkgver=4.1
+pkgrel=2
pkgdesc="GNOME audio player for transcription"
arch=('any')
url="https://github.com/gkarsay/parlatype"
license=('GPL3')
-depends=('gtk3' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'iso-codes')
-makedepends=('appstream' 'appstream-glib' 'meson' 'gettext' 'gobject-introspection' 'yelp-tools' 'desktop-file-utils' 'gtk-doc')
+depends=('gtk4' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'iso-codes' 'libadwaita')
+makedepends=('appstream' 'appstream-glib' 'meson' 'gettext' 'gobject-introspection' 'yelp-tools' 'desktop-file-utils' 'gtk-doc' 'cmake') # add pocketsphinx and/or deepspeech if needed
optdepends=('parlatype-libreoffice-extension: LibreOffice macros')
source=("https://github.com/gkarsay/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-b2sums=('7227a7b725f0bdae75ecf30cbc6fd06085ece95be1c73fb8019cb66ca00e9c8a3fa31e99ff38869045cedcc7871a7fa23bb4cbbcb442d143d85ecab3407d038c')
+b2sums=('6554c3702bb36da7c1242c783fa555b446c573a71a5cb862c4ac9dbae6f1cf6d3c9c880abce24f300fa932f88111646b55f16e7175b73e1c6a072810a0d68ddf')
build() {
cd "$pkgname-$pkgver"
- arch-meson build -Dgir=true -Dgtk-doc=true
+ arch-meson build -Dgir=true -Dgtk-doc=true # add -Dpocketsphinx=true and/or -Ddeepspeech=true if needed
cd build
ninja
}