summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea9b26065417..60c142a02ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Guillaume Hayot <ghayot@postblue.info>
pkgname=parlatype
-pkgver=1.6
-pkgrel=1
+pkgver=4.1
+pkgrel=2
pkgdesc="GNOME audio player for transcription"
arch=('any')
-url="https://gkarsay.github.io/parlatype/"
-license=('GPL')
-depends=('gtk3' 'gst-plugins-base' 'gst-plugins-good')
-makedepends=('libreoffice' 'meson' 'appstream' 'yelp-tools' 'python-atspi' 'sphinxbase' 'pocketsphinx')
-optdepends=('libreoffice: LibreOffice macros' 'gst-plugins-ugly: Play MP3 files')
+url="https://github.com/gkarsay/parlatype"
+license=('GPL3')
+depends=('gtk4' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'iso-codes' 'libadwaita')
+makedepends=('appstream' 'appstream-glib' 'meson' 'gettext' 'gobject-introspection' 'yelp-tools' 'desktop-file-utils' 'gtk-doc' 'cmake') # add pocketsphinx and/or deepspeech if needed
+optdepends=('parlatype-libreoffice-extension: LibreOffice macros')
source=("https://github.com/gkarsay/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('8150aab04988b6966863f8c42fbab7a8d096b52c859929a819b19ef307f878b9')
+b2sums=('6554c3702bb36da7c1242c783fa555b446c573a71a5cb862c4ac9dbae6f1cf6d3c9c880abce24f300fa932f88111646b55f16e7175b73e1c6a072810a0d68ddf')
build() {
cd "$pkgname-$pkgver"
- meson build --prefix=/usr
+ arch-meson build -Dgir=true -Dgtk-doc=true # add -Dpocketsphinx=true and/or -Ddeepspeech=true if needed
cd build
ninja
}