summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 17 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b69f8c2887ba..bf26b86cd411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=parsedmarc
-pkgver=6.5.4
-_commit=6efec4e6334bff28f7fd4ee89932d08307a70289 # Upstream does not tag releases - cherry-pick has commit message of release version
+pkgver=6.6.1
+_commit=7d7a3e0919bbe32aad59e516b4b0dd6ec9fdfc15 # Untagged release
pkgrel=1
pkgdesc='Python package and CLI for parsing aggregate and forensic DMARC reports'
arch=(any)
@@ -16,7 +16,7 @@ depends=('python-tqdm>=4.31.1'
'python-urllib3<1.25'
'python-urllib3>=1.21.1'
'python-requests>=2.2.16.0'
- python-publicsuffix2
+ 'python-publicsuffix2>=2.20190812'
'python-xmltodict>=0.12.0'
'python-geoip2>=2.9.0'
'python-imapclient>=2.1.0'
@@ -27,24 +27,23 @@ depends=('python-tqdm>=4.31.1'
'python-elasticsearch-dsl<7.0.0'
'python-elasticsearch-dsl>=6.3.1'
'python-kafka>=1.4.4'
- 'python-mailsuite>=1.1.0'
- python-nose
- python-pygments
- flake8
- python-collective-checkdocs
- python-jinja
- python-packaging
- python-imagesize
- python-sphinx-alabaster-theme
- python-babel
+ 'python-mailsuite>=1.3.0'
+ 'python-nose>=1.3.7'
+ 'flake8>=3.7.8'
+ 'python-collective-checkdocs>=0.2'
+ 'python-jinja>=2.10.1'
+ 'python-packaging>=19.1'
+ 'python-imagesize>=1.1.0'
+ 'python-sphinx-alabaster-theme>=0.7.12'
+ 'python-babel>=2.7.0'
'rstcheck>=3.3.1'
- python-sphinx
- python-sphinx_rtd_theme
- python-wheel
- python-codecov)
+ 'python-sphinx>=1.0.5'
+ 'python-sphinx_rtd_theme>=0.4.3'
+ 'python-wheel>=0.33.6'
+ 'python-codecov>=2.0.15')
makedepends=(python-setuptools)
source=($pkgname-$pkgver.tar.gz::https://github.com/domainaware/parsedmarc/archive/$_commit.tar.gz)
-sha512sums=('a8ef754b9838c794afcffbf35620f48f83bf6aa7ebab1f2521bcc26cd481ae9761d80333fa2a67462993d1c30bc76293acf44ec2908b82390def1bd8a442070e')
+sha512sums=('e2e074fd3b076ce1f5069e339e51b0db305fb6184c67b69aaa185f5ff10310eb2b103fdd8ce123d72dfe020b6646f146526ff8c4574f6095daeb950b16e6ac4f')
build() {
cd $pkgname-$_commit