summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8da6d7f71349..05d279f07f2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Horo <horo@yoitsu.moe>
pkgname=parsoid
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="A bidirectional wikitext parser and runtime"
arch=('any')
@@ -19,10 +19,16 @@ backup=(usr/share/webapps/parsoid/localsettings.js
usr/share/webapps/parsoid/config.yaml)
source=("https://github.com/wikimedia/parsoid/archive/v${pkgver}.zip"
"parsoid.service"
- "parsoid.install")
-sha512sums=("c6821d871edf2e23329693ff60eb9d8dd4fc3475982a5edfc4514d3e059a403f9b32e2b695d4074f077eba016f51ecf93c2cfac91961d36c54a77c97897bc1b7"
- "b4f8a2fc5119fa4741d79c66b5bb2282b274018ad548d383c6007fbe66d14ee1de6744a2cdcf1f8453ca055f48716598b42d3faecd29b81f61c06a54df64ed7d"
- "3b6fdba7a211ccfb038cd1fbe38214b439ce873d6c5bf99187e0c2be19052c2f28ebd322ddf5696f676ee426f177fec828399f859bda6cc4592518e9fa5bbdf5")
+ "parsoid.install"
+ "parsoid.sysusers"
+ "parsoid.tmpfiles")
+ sha512sums=(
+ "0d527df2d5a9b43ac33a52dbf2c8b71c63b55f341ca107d44f878b22c9e7a297b2e6492f77ae7ca88d2834d58fb14cb0d1a57271ec609515579c1031e5eac45b"
+ "3733d08751209fdef134940bbcce48efd0f380e13a8df466a7a1010450857a924aa364628242e4307cf40f4a34e60c1aeb1400d9a5b9fed88b448ed549e4d3f1"
+ "70473c30f7d78f40da1ab91c717e012575687e5edde18011d7a8759fc7ad0ad28a20514794a836d855b409a9becb4c779365d72dc3d5dcd62275d05f558876e8"
+ "7f2346af222052e2e685d859e0bb7a7c7c9f03988f772856e0888cad299cb3870afdc280feb9e2798e7989d3382f68f689d43a685b466ce9f138edb77b20de3a"
+ "6158afa3c276ddb5090166680621b7b9213f3d73b2d1a95181f5441631be039e7d454228d2f214f1411bb7f953475ddbd368e89eaa2288ac200ac666a57a6a99")
+
options=('!strip')
install="parsoid.install"
prepare() {
@@ -39,6 +45,8 @@ package() {
cp config.example.yaml config.yaml
cp -R . "${pkgdir}/usr/share/webapps/${pkgname}/"
install -Dm644 "${srcdir}/parsoid.service" "${pkgdir}/usr/lib/systemd/system/parsoid.service"
+ install -Dm644 "$srcdir"/parsoid.sysusers "$pkgdir"/usr/lib/sysusers.d/parsoid.conf
+ install -Dm644 "$srcdir"/parsoid.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/parsoid.conf
install -D "COPYING.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}