summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bcf06f4abfe..f6a834546a84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,19 +31,23 @@ source=(git+https://git.zx2c4.com/password-store.git)
sha256sums=(SKIP)
pkgver() {
- cd password-store
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir"/password-store
+ git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
}
check() {
- cd password-store
+ unset POSIXLY_CORRECT # remove once patched upstream
+ cd "$srcdir"/password-store
make test
}
package() {
- cd password-store
- make DESTDIR="${pkgdir}" WITH_ALLCOMP=yes install
+ cd "$srcdir"/password-store
+ make DESTDIR="$pkgdir" WITH_ALLCOMP=yes install
- cd contrib/dmenu
- install -Dm0755 passmenu "${pkgdir}/usr/bin/passmenu"
+ install -Dm755 -t "$pkgdir"/usr/bin contrib/dmenu/passmenu
+ install -Dm644 -t "$pkgdir"/usr/share/vim/vimfiles/plugin \
+ contrib/vim/redact_pass.vim
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/pass COPYING
+ install -Dm644 -t "$pkgdir"/usr/share/doc/pass README
}