summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b8aeb5f70eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Cédric Bellegarde <cedric.bellegarde@adishatz.org>
+
+pkgname=passbook
+pkgver=0.1
+pkgrel=1
+pkgdesc='A password manager for GNOME'
+arch=('any')
+url='https://gitlab.gnome.org/gnumdk/passbook'
+license=('GPL')
+depends=(
+ 'gtk3' 'python-cairo'
+ 'python-dbus' 'python-gobject'
+)
+makedepends=(
+ 'git' 'gobject-introspection' 'intltool' 'itstool' 'meson' 'python'
+)
+source=("git+https://gitlab.gnome.org/gnumdk/passbook.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson passbook build \
+ --libexecdir='lib/passbook'
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+
+# vim: ts=2 sw=2 et: