summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e375901d56f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Carson Rueter <roachh@protonmail.com>
+
+_pkgname='passmanpp'
+pkgname='passman++'
+pkgdesc='Incredibly simple and secure command-line password manager.'
+url="https://github.com/binex-dsk/$_pkgname/"
+license=('BSD')
+pkgver=1.1.0
+pkgrel=1
+source=("https://github.com/binex-dsk/$_pkgname/archive/$pkgver.zip")
+md5sums=('6191151651c0f1d5939b7097d485fa7c')
+provides=('passman')
+conflicts=('passman-git')
+depends=('botan' 'libsodium' 'qt5-base')
+arch=('x86_64')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver/src"
+ qmake passman.pro
+ make && make clean
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver/src"
+ install -Dm755 passman $pkgdir/usr/bin/passman
+}
+