summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48889ea98628
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Carson Rueter <bottomtext97@gmail.com>
+pkgname='passman'
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Super-secure, easy-to-use password manager."
+arch=('any')
+url="https://github.com/binex-dsk/passman-aur"
+license=('GPL3')
+provides=('passman')
+depends=('python3' 'python-sqlalchemy')
+source=("git+https://github.com/binex-dsk/passman-aur.git")
+md5sums=('SKIP')
+
+package() {
+ if [ -d ~/.config/passman != 0 ]; then mkdir ~/.config/passman; fi
+ install -Dm755 "${srcdir}/passman-aur/passman" "${pkgdir}/usr/bin/passman"
+ install -Dm755 "${srcdir}/passman-aur/passman.pyc" "${pkgdir}${HOME}/.config/passman/passman.pyc"
+}