summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2b975c9f722..6f39f63e0742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
-# Maintainer: Ramle <ramle@ramle.be>
+# Maintainer: Elmar <aur@ramle.be>
_pkgname=passmenu-otp
-pkgname=passmenu-otp-git
-pkgver="1.o"
+pkgname=$_pkgname-git
+pkgver=2623a08
pkgrel=1
pkgdesc="A simple extension of passmenu friendly to one-time passwords (OTP), often used in two-factor authentication (2FA)."
arch=('any')
url="https://github.com/petrmanek/$_pkgname"
license=('MIT')
+conflicts=('passmenu-otp')
+provides=("passmenu-otp=${pkgver}")
+
depends=(
- 'git'
- 'pass-otp'
- 'bash'
- 'dmenu'
- 'xdotool'
- )
+ 'git'
+ 'pass-otp'
+ 'bash'
+ 'dmenu'
+ 'xdotool'
+)
-source=("git+https://github.com/petrmanek/$_pkgname.git")
+source=("git+${url}")
sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --always
+}
+
package() {
install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "$_pkgname"