summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3f4c218438d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=patch-git
+pkgver=2.7.5.r17.g817d7d1
+pkgrel=1
+pkgdesc="A utility to apply patch files to original sources"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/patch/patch.html"
+license=('GPL3')
+depends=('glibc' 'attr')
+makedepends=('git' 'gettext')
+provides=('patch')
+conflicts=('patch')
+source=("git+https://git.savannah.gnu.org/git/patch.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "patch"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "patch"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "patch"
+
+ make check
+}
+
+package() {
+ cd "patch"
+
+ make DESTDIR="$pkgdir" install
+}