summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da5227702d47..4edd5a3d588f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,30 @@
# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Maintainer: speps <speps at aur dot archlinux dot org>
# Contributor: Max Pray a.k.a. Synthead <synthead@gmail.com>
# Contributor: clarence <catchfire at gmail dot com>
+
pkgname=patchage
-pkgver=0.5.0
-pkgrel=3
-pkgdesc="A modular patch bay for audio and MIDI systems"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A modular patch bay for audio and MIDI systems based on Jack and Alsa"
arch=('i686' 'x86_64')
url="http://drobilla.net/software/patchage"
-license=('GPL')
-depends=('dbus-glib' 'libglademm' 'hicolor-icon-theme'
- 'raul' 'flowcanvas<1.0.0' 'jack')
+license=('GPL3')
+depends=('ganv' 'jack' 'desktop-file-utils')
makedepends=('boost' 'python2')
-install=$pkgname.install
+install="$pkgname.install"
source=("http://download.drobilla.net/$pkgname-$pkgver.tar.bz2")
-sha256sums=('9bb9d1ba0205c0ad95c6dbecba56c513ff706f1057348d33ff7567bc9cbd89d2')
+md5sums=('d16a3fc045faff7fd70f3b4769b65698')
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd $pkgname-$pkgver
python2 waf configure --prefix=/usr
python2 waf build $MAKEFLAGS
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- python2 waf --destdir="$pkgdir" install
+ cd $pkgname-$pkgver
+ python2 waf install --destdir="$pkgdir"
}
# vim:set ts=2 sw=2 et: