summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49d3f16b4ce6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hexawolf <hexawolf@protonmail.com>
+
+pkgname=pause
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Wait for signal"
+arch=('any')
+url="https://hexawolf.dev/post/pause"
+license=('Unlicense')
+makedepends=('dietlibc' 'binutils' 'gcc')
+provides=('pause')
+source=("pause.c")
+sha256sums=('SKIP')
+
+build() {
+ diet -Os gcc -Wl,--gc-sections -ffunction-sections -fdata-sections pause.c -o pause
+ strip -s -R .comment -R .gnu.version pause
+}
+
+package() {
+ install -D -m 755 pause -t "${pkgdir}/usr/bin"
+}