summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25dae66f9826..50c70115d904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
# Contributor: Jonas Seibert <jonas+aur at seibert dot ninja>
# Contributor: Holger Rauch <holger dot rauch at posteo dot de>
+
pkgname=payara
-pkgver=5.2022.2
+pkgver=6.2022.1
pkgrel=1
pkgdesc="Jakarta EE (Java EE) & MicroProfile compatible application server for production and containerized deployments."
url="http://www.payara.fish/"
@@ -16,17 +17,17 @@ source=("https://search.maven.org/remotecontent?filepath=fish/${pkgname}/distrib
"${pkgname}-sysusers.conf"
"${pkgname}-tmpfiles.conf")
-sha256sums=('a956ee0084d9a857435ffa8008962242b3ec30a26335359cda9ff6b37e2e9249'
+sha256sums=('507ce4eb1c943d69fe184a8881123f8ae346edc22f8417c5c662cbdde788f237'
'ae84891616d6a4bd6a7059c707f81598340d4cb8369bb4fe9d922cf3f997cdfb'
'a0d04db70b87b1105bc762d23e49b527ec94bd21ea78bf9c56d54343a8711dfb'
'd04df28962fa7b033b0767846e424b7ea9537530afd7006a75505e318ec28b35')
package() {
install -d ${pkgdir}/opt
- cp -r "${pkgname}5" "${pkgdir}/opt/${pkgname}"
+ cp -r "${pkgname}${pkgver:0:1}" "${pkgdir}/opt/${pkgname}"
install -D -t "${pkgdir}/usr/lib/systemd/system/" -m 644 "${pkgname}.service"
install -D -m 644 "${pkgname}-sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
install -D -m 644 "${pkgname}-tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
chmod -R u=rwX,g=rwX,o=rX "${pkgdir}/opt/${pkgname}"
}
-# vim:set ts=4 sw=4:
+# vim:set ts=4 sw=4 et: