summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 4 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4acc96541be2..e86939995b3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
pkgname=pb-git
-pkgver=r311.529e8fc
+pkgver=r357.dc04f7f
pkgrel=1
pkgdesc="My attempt at a light pastebin"
arch=('any')
url="https://github.com/ptpb/pb"
license=('GPLv3')
-depends=('python' 'python-werkzeug' 'python-flask-git' 'python-yaml'
+depends=('python' 'python-werkzeug' 'python-flask' 'python-yaml'
'python-requests' 'python-docutils' 'python-xdg'
'python-pymongo' 'python-markdown' 'python-dateutil'
'uwsgi' 'uwsgi-plugin-python'
'python-click' 'python-pygments' 'python-pytz')
-makedepends=('python-setuptools' 'git' 'graphicsmagick' 'npm')
+makedepends=('python-setuptools' 'git')
#checkdepends=('tox' 'python-pytest' 'python-pytest-cov')
+optdepends=('pbs-git: pb styles and static resources')
provides=('pb')
backup=('etc/xdg/pb/config.yaml' 'etc/uwsgi/pb.ini')
@@ -26,21 +27,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd $pkgname
-
- npm install
- npm install grunt-cli
-
- # npm and grunt are retarded pieces of shit
- (
- cd node_modules/pbs
- npm install
- )
-
- node_modules/grunt-cli/bin/grunt
-}
-
build() {
cd $pkgname