summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b47e7e9c6f9e..cc74ca81ce2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,25 @@
# Contributor: Noel Kuntze <noel@familie-kuntze.de>
pkgname=pcs
-pkgver=0.9.155
-pkgrel=3
+pkgver=0.9.157
+pkgrel=1
pkgdesc='pacemaker corosync shell utility for cluster configuration'
arch=('any')
url='http://clusterlabs.org/'
license=('GPL2')
depends=('python' 'python-lxml')
-#makedepends=('ruby-bundler')
+makedepends=('ruby-bundler')
source=("https://github.com/ClusterLabs/$pkgname/archive/$pkgver.tar.gz")
-md5sums=('5c36c47c7f2199c93716e2b4e641e919')
+md5sums=('9e235349882b3090d4a9f09ffdd4656b')
+
+build() {
+ cd $pkgname-$pkgver
+ make -C pcsd BUILD_GEMS=true build_gems
+}
package() {
cd $pkgname-$pkgver
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" BUILD_GEMS=false install install_pcsd
rm -fr "${pkgdir}/usr/bin"
mv "${pkgdir}/usr/sbin" "${pkgdir}/usr/bin"
}