summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 951b540d257b..2ad2662c71f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pcsxr-gtk2
_pkgname=pcsxr
pkgver=1.9.92
-pkgrel=1
+pkgrel=2
pkgdesc='A Sony PlayStation (PSX) emulator based on the PCSX-df project (Gtk2 version)'
arch=('i686' 'x86_64')
url='https://pcsxr.codeplex.com/'
@@ -16,14 +16,17 @@ makedepends_i686+=('nasm')
# Accessible through /srv/ftp/other/community on nymeria.
source=("https://sources.archlinux.org/other/community/pcsxr/pcsxr-${pkgver}.tar.bz2"
-"link_order.patch")
+"link_order.patch"
+"static-declaration.patch")
md5sums=('28411aed0b4424f97227d94bdefaec83'
- 'ce021bfc4c19e553a2cdb95b7ca1eb01')
+ 'ce021bfc4c19e553a2cdb95b7ca1eb01'
+ '0e679ab20973c11a2f943b3018db1e97')
build() {
cd ${_pkgname}-${pkgver}
patch -Np1 -i "${srcdir}/link_order.patch"
+ patch -Np1 -i "${srcdir}/static-declaration.patch"
./configure --prefix=/usr --enable-libcdio --enable-opengl
make
}