summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6845297824ee..382cea8af3fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,22 @@
pkgname=pdfcropmargins
PkgName=pdfCropMargins
-CodeChemin="24/d9/d9bb0286d9c8e0aa2a752c7bad654f6491daefaab6b1737544ab62caf0db"
-pkgver=1.0.9
-pkgrel=1
+CodeChemin="ad/af/17707613067642f6ca164e9772ac4af3d81647b44778cbf62cb8ba4a0d9a"
+pkgver=2.1.2
+pkgrel=2
pkgdesc="Automatically crops the margins of PDF files"
url="https://pypi.org/project/pdfCropMargins/"
arch=('any')
license=('GPL')
-depends=('python-setuptools' 'python-wheel' 'python-pysimplegui' 'python-pymupdf' 'python-pypdf2' 'ghostscript' 'poppler')
+makedepends=('python-pip')
+depends=('python-setuptools' 'python-wheel' 'python-pymupdf' 'python-pypdf2')
+optdepends=('ghostscript' 'poppler')
+conflicts=('python-pysimplegui')
install=${pkgname}.install
-source=("https://files.pythonhosted.org/packages/$CodeChemin/$PkgName-$pkgver.tar.gz")
-md5sums=('e60e276060faa5ba9316dce475e2fa50')
-
-
-build() {
- cd $srcdir/$PkgName-$pkgver
- python setup.py build
-}
+source=("https://files.pythonhosted.org/packages/$CodeChemin/$PkgName-$pkgver-py2.py3-none-any.whl")
+md5sums=('d5e3f85db0266045da472bf2069c3582')
package() {
- cd $srcdir/$PkgName-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd ${srcdir}
+ pip install --root="$pkgdir" $PkgName-$pkgver-py2.py3-none-any.whl
}