summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 464c10b3f336..6047bf217009 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Olivier Mehani <shtrom-aur@ssji.net>
pkgname=pdfsizeopt-git
-pkgver=r263.cba29b4
-pkgrel=2
+pkgver=r271.6f1d901
+pkgrel=1
pkgdesc="PDF file size optimizer"
arch=(any)
url="https://github.com/pts/pdfsizeopt"
@@ -15,18 +15,12 @@ makedepends=('git')
optdepends=("multivalent-pdf-tools: to optimise cross reference table and object serialisation [use --use-multivalent=true]"
"pngout: to optimise the size of PNG parts [use --use-jbig2=true]"
"jbig2enc: to manage JBIG2 parts [use --use-pngout=true]")
-source=("git+https://github.com/pts/pdfsizeopt"
- "archpackage.patch")
+source=("git+https://github.com/pts/pdfsizeopt")
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/${pkgname%-git}"
- patch -p1 -i "$srcdir/archpackage.patch"
-}
-
build() {
cd "$srcdir/${pkgname%-git}"
./mksingle.sh
@@ -37,5 +31,4 @@ package() {
install -D -m 755 $srcdir/pdfsizeopt/pdfsizeopt.single $pkgdir/usr/bin/pdfsizeopt
}
-md5sums=('SKIP'
- '6ccd8d71b9833b30ae027aad6d81302b')
+md5sums=('SKIP')