summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 878b5cfa1031..9627c4f17d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://wiki.archlinux.org/index.php/Creating_packages
pkgname=pearl-git
-pkgver=r71.2915577
+pkgver=r75.6458dc7
pkgrel=1
pkgdesc="Package manager for dotfiles, plugins, programs and any form of code accessible via git. Allow to easily share and sync packages across systems and have them ready to work out of the box."
arch=('any')
@@ -49,11 +49,8 @@ package() {
mkdir -p "${pkgdir}/opt/"
cp -R "${srcdir}/${pkgname%-git}" "${pkgdir}/opt/${pkgname%-git}"
- mkdir -p "${pkgdir}/etc/profile.d/"
- echo "export PATH=\$PATH:/opt/${pkgname%-git}/bin" > "${pkgdir}/etc/profile.d/${pkgname%-git}"
- chmod +x "${pkgdir}/etc/profile.d/${pkgname%-git}"
- echo "set -x PATH \$PATH /opt/${pkgname%-git}/bin" > "${pkgdir}/etc/profile.d/${pkgname%-git}.fish"
- chmod +x "${pkgdir}/etc/profile.d/${pkgname%-git}.fish"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s ../../opt/${pkgname%-git}/bin/${pkgname%-git} ${pkgdir}/usr/bin/${pkgname%-git}
}
# vim:set ts=2 sw=2 et: