summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..804c35c236d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Per Osbeck <per@osbeck.com>
+pkgname=perfops-cli
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A simple command line tool to interact with hundreds of servers around the world. Run benchmarks and debug your infrastructure without leaving your console."
+arch=(x86_64)
+url="https://perfops.net"
+license=('APACHE')
+makedepends=('git' 'go')
+source=("$pkgname::git+https://github.com/ProspectOne/$pkgname.git#tag=v$pkgver")
+md5sums=(SKIP)
+
+build() {
+ cd "$pkgname"
+ PERFOPS_BUILD_PLATFORMS=linux bash hack/build-all.sh
+}
+
+# check() {
+# #
+# }
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "release/perfops-linux-amd64" "$pkgdir/usr/bin/perfops-cli"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}