summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 36 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98edc255ff05..cc930d78ee5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,51 @@
-# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.27
+# Contributor: Swift Geek <swiftgeek «at» gmail.com>
+# Contributor: Nick Østergaard <oe.nick at gmail dot com>
-pkgname='perl-alien-wxwidgets'
-pkgver='0.64'
-pkgrel='1'
+pkgname=perl-alien-wxwidgets
+pkgver=0.64
+pkgrel=1
pkgdesc="building, finding and using wxWidgets binaries"
arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=('perl')
+url="http://search.cpan.org/dist/Alien-wxWidgets"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0' 'wxgtk2.8' 'perl-module-pluggable') # Install perl-module-pluggable from AUR
makedepends=()
-url='http://search.cpan.org/dist/Alien-wxWidgets'
-source=('http://search.cpan.org/CPAN/authors/id/M/MD/MDOOTSON/Alien-wxWidgets-0.64.tar.gz')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/M/MD/MDOOTSON/Alien-wxWidgets-${pkgver}.tar.gz")
md5sums=('12b6492a87cf165a4f0cd7254ccfab11')
-sha512sums=('4b687527936dc88fcf35e103bb6effea2dffaf2e313d2ff4a6000a20d240fcb0bde165dbf92f2cc8e2ddf1780f58e585001c261413cfc2ca53c0c617acbeb359')
-_distdir="Alien-wxWidgets-0.64"
-build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
+prepare() {
+ export _src_dir="$srcdir/Alien-wxWidgets-$pkgver"
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ warning "If build stage tries to pull and compile WX - interrupt as resulting package wont work"
+ warning "If package contains gtk2_3_0_0_uni_gcc_3_4.pm it is an improper package - do not attempt to install it - report in comments instead"
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+ # HAX HAX HAX - hax first in PATH to replace /usr/bin
+ mkdir ${srcdir}/hax
+ ln -s /usr/bin/wx-config-2.8 ${srcdir}/hax/wx-config
+ export PATH="${srcdir}/hax:${PATH}"
}
-check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+build() {
+ cd "$_src_dir"
+ /usr/bin/perl Makefile.PL
+ make
}
-package() {
- cd "$srcdir/$_distdir"
+check () {
+ cd "$_src_dir"
+ make test
+}
+
+package () {
+ cd "$_src_dir"
+ echo "$_src_dir"
make install
+ # remove perllocal.pod and .packlist
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: