summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 33 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fab4ef6bb44..588dce146ee2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,48 @@
-# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
-# Maintainer: ordoban <dirk.langer@vvovgonik.de>
+# Contributor: ordoban <dirk.langer@vvovgonik.de>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-asa'
-_cpanname='asa'
-pkgver='1.03'
-pkgrel='3'
-pkgdesc='Lets your class/object say it works like something else.'
+pkgver='1.04'
+pkgrel='1'
+pkgdesc="Lets your class/object say it works like something else"
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-depends=('perl>=5.5.0')
-makedepends=('perl-module-install')
-url="http://search.cpan.org/~adamk/$_cpanname-$pkgver/"
-source=("http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/$_cpanname-$pkgver.tar.gz")
-md5sums=('ad3d82114f569892d65163e8623d50e4')
-
-# Function to change to the working directory and set
-# environment variables to override undesired options.
-prepareEnvironment() {
- cd "$srcdir/$_cpanname-$pkgver"
- export \
- PERL_MM_USE_DEFAULT=1 \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-}
+depends=('perl>=5.006')
+makedepends=()
+url='https://metacpan.org/release/asa'
+source=('https://cpan.metacpan.org/authors/id/E/ET/ETHER/asa-1.04.tar.gz')
+md5sums=('cbe6d1db505eb4eaa2bf35a637fc0451')
+sha512sums=('8584036c1c520741fe1bd4fb2875a86a46e2abd07d441078ef64bd90a31ba13b001079b020263add298ff004e094f8380b2ec590aacfc808cc1ba4be6b177b0a')
+_distdir="asa-1.04"
build() {
- prepareEnvironment
- /usr/bin/perl Makefile.PL
- make
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
}
check() {
- prepareEnvironment
- make test
+ cd "$srcdir/$_distdir"
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="."
+ make test
}
package() {
- prepareEnvironment
- make install
+ cd "$srcdir/$_distdir"
+ make install
- # Remove "perllocal.pod" and ".packlist".
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: