summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 905c7dc3a335..a4d333a8467f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
-# Contributor: xRemaLx <anton.komolov@gmail.com>
+# Contributor: CpanBot <cpanbot at sch bme hu>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-carp-assert-more'
-_pkgname='Carp-Assert-More'
-pkgver='1.16'
+pkgver='2.3.0'
pkgrel='1'
-pkgdesc="convenience wrappers around Carp::Assert"
+pkgdesc="unknown"
arch=('any')
-license=('PerlArtistic' 'GPL')
+license=('Artistic2.0')
options=('!emptydirs')
-depends=('perl-carp-assert')
-makedepends=('perl-test-exception')
-url='http://search.cpan.org/dist/Carp-Assert-More'
-source=("http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE/${_pkgname}-${pkgver}.tar.gz")
-sha512sums=('9f81604574eab5a0a5003ad747ffec3a3dd33bc63e67d12697e4e30de8cb234a73e225f82a4d0f31576e19382cc2d6a402962f5fe1e4c5289e080ca23b30c0fe')
+depends=('perl-test-exception>=0' 'perl>=5.10.1')
+makedepends=()
+url='https://metacpan.org/release/Carp-Assert-More'
+source=('http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE/Carp-Assert-More-2.3.0.tar.gz')
+md5sums=('f10ce02f0b15caa6d7b1e34a967578d2')
+sha512sums=('ba0da716230e17d6711698c5909a096df992aacaf64e5dd9ea12795ecb4c86e66e71d6967bd0fdbfb20f202e5fd0e582befb3145f52f89af09a681263046354d')
+_distdir="Carp-Assert-More-2.3.0"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -21,21 +23,21 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "$srcdir/$_distdir"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "$srcdir/$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "$srcdir/$_distdir"
make install
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}