summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b343b5682aa1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=perl-date-parse
+pkgver=2.30
+pkgrel=2
+pkgdesc='Parse date strings into time values'
+arch=('any')
+url='http://search.cpan.org/~gbarr/TimeDate-2.30/'
+license=('GPL' 'PerlArtistic')
+depends=('perl' )
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/TimeDate-${pkgver}.tar.gz")
+md5sums=('b1d91153ac971347aee84292ed886c1c')
+
+build() {
+ cd "$srcdir"/TimeDate-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir"/TimeDate-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: