summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD70
1 files changed, 39 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 788e6fd4562a..e4e2935b7954 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,58 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
# Generator : CPANPLUS::Dist::Arch 1.28
-pkgname='perl-file-touch'
-pkgver='0.09'
+set -u
+_perlmod='File-Touch'
+_modnamespace='File'
+pkgname="perl-${_perlmod,,}"
+pkgver='0.11'
pkgrel='1'
-pkgdesc="update file access and modification times, optionally creating files if needed"
+pkgdesc="${_perlmod//-/::} update file access and modification times, optionally creating files if needed"
arch=('any')
+#url='http://search.mcpan.org/dist/File-Touch'
+url="http://search.cpan.org/dist/${_perlmod}"
license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
depends=('perl>=5.006')
-makedepends=()
-url='http://search.mcpan.org/dist/File-Touch'
-source=('http://search.mcpan.org/CPAN/authors/id/N/NE/NEILB/File-Touch-0.09.tar.gz')
-md5sums=('250dd8951c9a9e6cfccddad04d8096b9')
-sha512sums=('f2bd4e53ff1b57d9295e08a6445406bde1cd9e10860450612086c20177542ec3e954043be405e262ea39f331d6b51b3ea21ce3183e8538c046d5799af106d053')
-_distdir="File-Touch-0.09"
+options=('!emptydirs')
+_srcdir="${_perlmod}-${pkgver}"
+#source=("https://cpan.metacpan.org/authors/id/N/NE/NEILB/${_perlmod}-${pkgver}.tar.gz")
+_verwatch=("http://www.cpan.org/modules/by-module/${_modnamespace}/" "${_perlmod}-\([0-9\.]*\)\.tar\.gz" 'l')
+source=("${_verwatch[0]}${_perlmod}-${pkgver}.tar.gz")
+md5sums=('caf4101a022f66c88f5fb4383b3f6388')
+sha256sums=('e379a5ff89420cf39906e5ceff309b8ce958f99f9c3e57ad52b5002a3982d93c')
+sha512sums=('7f1d46fe26de863388854e222b0229e29f0575ee0d8ed59f8cc447a39bc40d7fda425a394a4c3bbc9f561370b6c82cec9c65f4bb784ebba4ff72dbcb5c0a4cd0')
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+ set -u
+ cd "${_srcdir}"
+ PERL_MM_USE_DEFAULT='1' \
+ PERL5LIB='' \
+ PERL_AUTOINSTALL='--skipdeps' \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
+ MODULEBUILDRC=/dev/null \
+ perl 'Makefile.PL'
+ make
+ set +u
}
check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ set -u
+ cd "${_srcdir}"
+ #PERL_MM_USE_DEFAULT='1' \\
+ #PERL5LIB='' \\
+ make test
+ set +u
}
package() {
- cd "$srcdir/$_distdir"
+ set -u
+ cd "${_srcdir}"
make install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "${pkgdir}" -name '.packlist' -o -name 'perllocal.pod' -delete
+ set +u
}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
+set +u
# vim:set ts=2 sw=2 et: