summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 711289a7b34c..23b702931c56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,31 @@
# Maintainer: 3ED <krzysztof1987 at gmail dot com>
#
pkgname=perl-file-trash-freedesktop
-_lastauthor=P/PE/PERLANCAR
+_author=PERLANCAR
_pkgname=File-Trash-FreeDesktop
-pkgver=0.18
+pkgver=0.19
pkgrel=1
pkgdesc='freedesktop.org trash specification'
arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=('perl-file-remove' 'perl-log-any' 'perl-file-homedir' 'perl-sys-filesystem' 'perl-sys-filesystem-mountpoint' 'perl-file-moreutil' 'perl-list-moreutils' 'perl-log-any-iflog')
-checkdepends=('perl-file-slurp-tiny' 'perl-file-chdir' 'perl-test-exception')
+license=('PerlArtistic')
+depends=(
+ 'perl-file-homedir'
+ 'perl-file-moreutil'
+ 'perl-file-remove'
+ 'perl-sys-filesystem'
+ 'perl-sys-filesystem-mountpoint'
+ 'perl-list-moreutils'
+ 'perl-log-ger')
+checkdepends=(
+ 'perl-file-slurp-tiny'
+ 'perl-file-chdir'
+ 'perl-test-exception')
url="https://metacpan.org/release/${_pkgname}"
+
+options=('!emptydirs')
+_lastauthor=${_author:0:1}/${_author:0:2}/${_author}
source=(https://cpan.metacpan.org/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
-sha512sums=('9ee5eb422fd57a5a6afaebc3159b68be8e2d5d565bab6a3b38b0b16ca9bc76da3f9ac052942ed5c8c68b9ee92741f9a909e035955115a83e7707373de29a1bc9')
+sha512sums=('1205e677be5c13aba92aa6db707b438fccb27d52aa57a528eab6a9899f2a780300a3e8350d2d3da1ae2f4c85c403c954861b57dc323938dc45e7c8008e5ae342')
build() {
export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" \