summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 697ef9a885f4..9a5dcbed6c84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.32
+_distname='Hash-Util-FieldHash-Compat'
pkgname='perl-hash-util-fieldhash-compat'
-pkgver='0.07'
+pkgver='0.11'
pkgrel='1'
pkgdesc="Use Hash::Util::FieldHash or ties, depending on availability"
arch=('any')
-license=('PerlArtistic' 'GPL')
+license=('LicenseRef-GPL-1.0-or-later OR Artistic-1.0-Perl')
options=('!emptydirs')
depends=('perl')
-makedepends=()
-checkdepends=('perl-test-use-ok')
-url='http://search.mcpan.org/dist/Hash-Util-FieldHash-Compat'
-source=('http://search.mcpan.org/CPAN/authors/id/E/ET/ETHER/Hash-Util-FieldHash-Compat-0.07.tar.gz')
-md5sums=('e53d60f6857fb0d3fae893030441b315')
-sha512sums=('1d12a40a17c7ba3ca82cfda975580dc83f9475db4784988a141ed15a6d4c6bf9fda1c223023c68e603b51dfa2166620a679600ccab00265da3c1042d7a7ee7f6')
-_distdir="Hash-Util-FieldHash-Compat-0.07"
+url="https://metacpan.org/release/$_distname"
+_author='ETHER'
+_licensefilename_SPDX_GPL1='GPL-1.0-or-later.txt'
+source=("https://search.cpan.org/CPAN/authors/id/${_author::1}/${_author::2}/$_author/$_distname-$pkgver.tar.gz"
+ "${_distname}-LICENCE-${_licensefilename_SPDX_GPL1}::https://raw.githubusercontent.com/Perl/perl5/perl-5.10.0/Copying")
+sha512sums=('a38397ba17587d85ed88020c85bd4d7c36798a9e8fa46490017ea84d30c6541f32a621a9ef585d57dbb49f39791d5644f329e956d4be9e0ec01918eb782eae9c'
+ 'f3e5cce80bb15147bcb998320e670d2e04ae9cef0425181c4123471b781c6f56bd8b3e71fef2d6ab0f02b5fb8591d7ecb26ddc09ba3d2fb2f9ef7a538f4ac998')
+_distdir="$_distname-$pkgver"
+
+prepare() {
+ cd "$srcdir/$_distdir"
+
+ echo "Preparing license resources..."
+ cp --verbose "../$_distname-LICENCE-$_licensefilename_SPDX_GPL1" "LICENCE-$_licensefilename_SPDX_GPL1"
+}
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -40,12 +50,7 @@ check() {
package() {
cd "$srcdir/$_distdir"
make install
-
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
-}
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et:
+ install -Dm644 LICENCE* -t "$pkgdir/usr/share/licenses/$pkgname"
+}