summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a73ce115c7a..7f691e325d76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
pkgname=perl-io-async
_dist='IO-Async'
pkgver=0.802
-pkgrel=1
+pkgrel=2
pkgdesc="Asynchronous event-driven programming"
arch=('any')
url="https://metacpan.org/release/IO-Async"
license=('GPL' 'PerlArtistic')
depends=('perl>=5.10.0' 'perl-future' 'perl-struct-dumb')
makedepends=('perl-module-build')
+checkdepends=('perl-future-io' 'perl-test-fatal' 'perl-test-identity' 'perl-test-metrics-any' 'perl-test-refcount')
options=('!emptydirs' 'purge')
source=("https://cpan.metacpan.org/authors/id/P/PE/PEVANS/$_dist-$pkgver.tar.gz")
sha256sums=('e582731577767c47eac435ef2904663d4a750b0e6802a4a6189a37f0cb308738')
@@ -23,6 +24,13 @@ build() {
./Build
}
+check() {
+ cd $_dist-$pkgver
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ ./Build test
+}
+
package() {
cd $_dist-$pkgver
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT