summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee8fe212a80c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=perl-latexml-git
+_realname=LaTeXML
+pkgver=0.8.2.445.g38fc034e
+pkgrel=1
+pkgdesc="LaTeX to XML converter"
+arch=('any')
+license=('custom')
+url="http://dlmf.nist.gov/LaTeXML/"
+depends=('perl' 'perl-parse-recdescent' 'perl-text-unidecode'
+ 'imagemagick6' 'perl-xml-libxml'
+ 'perl-xml-libxslt' 'db' 'texlive-core'
+ 'perl-image-size' 'perl-file-which'
+ 'perl-libwww' 'perl-io-string' 'perl-archive-zip')
+options=('!emptydirs')
+provides=('perl-latexml')
+conflicts=('perl-latexml')
+source=("git+https://github.com/brucemiller/LaTeXML.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${_realname}
+ printf "%s" $(git describe | cut -c2-| tr - .)
+}
+
+build() {
+ cd ${_realname}
+
+ # install module in vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor INSTALLVENDORBIN=/usr/bin INSTALLVENDORSCRIPT=/usr/bin TEXMF=/usr/share/texmf
+ make
+}
+
+package() {
+ cd ${_realname}
+ make install DESTDIR="$pkgdir"
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" -name .packlist -delete
+ # add liense file
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ # add manual
+ install -Dm644 manual.pdf "$pkgdir"/usr/share/$pkgname/doc/manual.pdf
+}