summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..573b370bf400
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: jsteel <mail at jsteel dot org>
+# Contributor: Petrenko Alexey <alexey-p at uralweb dot ru>
+
+pkgname=perl-lwp-protocol-socks
+pkgver=1.6
+pkgrel=1
+pkgdesc='Adds support for the socks protocol and proxy facility'
+url='http://search.cpan.org/~scr/LWP-Protocol-socks-1.3/'
+depends=('perl-libwww' 'perl-io-socket-ssl' 'perl-io-socket-socks' 'perl-lwp-protocol-https')
+arch=('any')
+license=('GPL')
+source=(http://search.cpan.org/CPAN/authors/id/S/SC/SCR/LWP-Protocol-socks-$pkgver.tar.gz)
+md5sums=('251f88101bb59207171f126c190faac9')
+
+build() {
+ cd "$srcdir/LWP-Protocol-socks-$pkgver"
+
+ perl Makefile.PL INSTALLDIRS=vendor
+
+ make
+}
+
+check() {
+ cd "$srcdir/LWP-Protocol-socks-$pkgver"
+
+ make test
+}
+
+package() {
+ cd "$srcdir/LWP-Protocol-socks-$pkgver"
+
+ make DESTDIR="$pkgdir"/ install
+
+ # Removing unnecessary stuff
+ find "$pkgdir" -type f -name 'perllocal.pod' -delete;
+ find "$pkgdir" -type f -name '.packlist' -delete;
+}