summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2bcb69f980c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Generated by Xyne::Arch::CPAN 0.07
+
+pkgname=perl-mail-gpg
+pkgver=1.0.12
+pkgrel=1
+pkgdesc="Handling of GnuPG encrypted / signed mails"
+arch=('any')
+url="https://metacpan.org/pod/Mail::GPG"
+license=('PerlArtistic')
+source=("https://cpan.metacpan.org/authors/id/J/JR/JRED/Mail-GPG-$pkgver.tar.gz")
+md5sums=('4e18ab540a57750b1dbcbf41579a5787')
+sha256sums=('a7877c9a4d61d86017606f8b25864f4df48d4c494ab343a3e712a6e9da23e6ec')
+depends=('perl' 'perl-gnupg-interface' 'perl-encode-locale' 'perl-mime-tools' 'perl-mailtools')
+makedepends=('perl-module-build')
+options=(!emptydirs)
+
+build() {
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Makefile.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+
+ else
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Build.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ PERL_MM_USE_DEFAULT=1 perl Build.PL INSTALLDIRS=vendor
+ ./Build
+
+ else
+ echo "error: failed to detect build method for $pkgname"
+ echo "you may be able to fix this by editing the PKGBUILD"
+ return 1
+ fi
+ fi
+
+}
+
+package() {
+echo "pkg starts here"
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Makefile.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ make install DESTDIR="${pkgdir}"
+ else
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Build.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ ./Build install destdir=${pkgdir}
+
+ else
+ echo "error: failed to detect build method for $pkgname"
+ echo "you may be able to fix this by editing the PKGBUILD"
+ return 1
+ fi
+ fi
+
+ # remove perllocal.pod and .packlist
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+}
+
+# vim:set ts=2 sw=2 et:
+
+