summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 17 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69b597386a81..396c0488143d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,7 @@
-# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
pkgname=perl-metabase-fact
-pkgver=0.024
+pkgver=0.025
pkgrel=1
_author="D/DA/DAGOLDEN"
_perlmod="Metabase-Fact"
@@ -45,50 +43,33 @@ perl-metabase-user-secret
)
options=(!emptydirs)
source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('dc19950ed8c3199a7a89f0c5f06bf682443d5d3d2c0d7a683a63f488a5100c71')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
build(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- /usr/bin/perl Makefile.PL
+ if [ -f Makefile.PL ]; then
+ perl Makefile.PL
make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- /usr/bin/perl Build.PL
- perl Build
+ else
+ perl Build.PL
+ ./Build
fi
}
check(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
+ if [ -f Makefile.PL ]; then
make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
+ else
+ ./Build test
fi
}
package(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
fi
-
- # remove perllocal.pod and .packlist
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-
-sha256sums=('4aed9de5424cf5053858153cf2b7c0569687969355c9e87ed217a44c62fd8528')